$re = '/(mul)\((\d{1,3}),(\d{1,3})\)|(do)\(\)|(don\'t)\(\)/';
$str = '%why();how()*-],+!mul(696,865)why()from()how():,;&select()mul(894,569):mul(648,114);[:from(657,891)how()mul(740,402)what()&/,do()~^why()who(762,850)mul(80,670)what()^mul(627,741),[?<\'when()?-{/mul(609,307)mul(432,475)why()>/,don\'t(),mul(325,720)how(555,834)-]~]who()from()mul(823,923)<mul(884,851)/?<;-#!\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);