re = /^(?:0[1-9]|1[012])[- \/.](?:0[1-9]|[12][0-9]|3[01])[- \/.](?:19|20)\d\d$/m
str = '34/14/2100
08/07/2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end