# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<buffer name=\"[^\"]*Lut[^\"]*\">.*?<\/buffer>"
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<pimp xmlns:dt=\"urn:schemas-microsoft-com:datatypes\">\n"
" <dllPath>C:\\ReplayCode\\Apps\\Pimp</dllPath>\n"
" <buffers> \n"
" <buffer name=\"InputMask\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"MaskErode\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"BlablaLutBla\">\n"
" <width>256</width>\n"
" <height>256</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"MaskClose\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"2ndLutBlabla\">\n"
" <width>256</width>\n"
" <height>256</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"InputVis\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>3</channels>\n"
" <type>IMG</type>\n"
" </buffer> \n"
" <buffer name=\"AddMaskEdge\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"EdgeVis\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>3</channels>\n"
" <type>IMG</type>\n"
" </buffer> \n"
" <buffer name=\"GrayEdge\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"EdgeMaskMulThreshold\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer>\n"
" <buffer name=\"MaskMulEdge\">\n"
" <width>5120</width>\n"
" <height>3072</height>\n"
" <data>UCHAR</data>\n"
" <channels>1</channels>\n"
" <type>IMG</type>\n"
" </buffer> \n"
" </buffers> ")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.