$re = '/[^{}]*{\s*([^{}]+)?}?\s*[^{}]*/';
$str = '{First level{Second level{Third level} } {And so on...}{ {whitespace is not a string}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);