const regex = /\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\b', 'gmi')
const str = `DMA-WS -> Requested name does not exist
DCTM_FSS -> Requested name does not exist
CHSA0884 -> Requested name does not exist
CHWU2550101 -> Requested name does not exist
LPM.CSINTRA.NET -> Requested name does not exist
WPAD -> Requested name does not exist
WWW.FOXNEWS.COM -> Requested name does not exist
USWT2507857 -> Requested name does not exist
GBLADHEDANI -> Requested name does not exist
WWW.GOOGLE.COM -> Requested name does not exist
WWW.ESPN.COM -> Requested name does not exist
T.CO -> Requested name does not exist
DPM.DEMDEX.NET -> Requested name does not exist
US-U.OPENX.NET -> Requested name does not exist
SYNC.1RX.IO -> Requested name does not exist
IB.ADNXS.COM -> Requested name does not exist
WWW.YOUTUBE.COM -> Requested name does not exist
CDN.KRXD.NET -> Requested name does not exist
APIS.GOOGLE.COM -> Requested name does not exist
CDN.DIGITRU.ST -> Requested name does not exist
ID.GOOGLE.COM -> Requested name does not exist
GEO.MOATADS.COM -> Requested name does not exist
VARS.HOTJAR.COM -> Requested name does not exist
ACDN.ADNXS.COM -> Requested name does not exist
* -> 0.33.0.1
S7.ADDTHIS.COM -> Requested name does not exist
C.BETRAD.COM -> Requested name does not exist
OGS.GOOGLE.COM -> Requested name does not exist
ML314.COM -> Requested name does not exist
D.AGKN.COM -> Requested name does not exist
SNYC17P15002 -> Requested name does not exist
SC.IASDS01.COM -> Requested name does not exist
API.RLCDN.COM -> Requested name does not exist
SSL.GSTATIC.COM -> Requested name does not exist
SYNC.TEADS.TV -> Requested name does not exist
TRC.TABOOLA.COM -> Requested name does not exist
SF.SYMCD.COM -> Requested name does not exist
MB.MOATADS.COM -> Requested name does not exist
SNYC50P02006 -> Requested name does not exist
GBLADHEDANI -> 255.255.255.255
C1.ADFORM.NET -> Requested name does not exist
DISQUS.COM -> Requested name does not exist
EB2.3LIFT.COM -> Requested name does not exist
PORTAL.ADP.COM -> Requested name does not exist
STATIC.ADP.COM -> Requested name does not exist
CTI.W55C.NET -> Requested name does not exist
WWW.BING.COM -> Requested name does not exist
MY.ADP.COM -> Requested name does not exist
DTS.INNOVID.COM -> Requested name does not exist
GU.DYNTRK.COM -> Requested name does not exist
TAGS.TIQCDN.COM -> Requested name does not exist
SYNC.JIVOX.COM -> Requested name does not exist
RP.GWALLET.COM -> Requested name does not exist
FED.ADP.COM -> Requested name does not exist
AP.LIJIT.COM -> Requested name does not exist
I.LIADM.COM -> Requested name does not exist
RTAX.CRITEO.COM -> Requested name does not exist
SYNC.BFMIO.COM -> Requested name does not exist
A.RFIHUB.COM -> Requested name does not exist
T.A3CLOUD.NET -> Requested name does not exist
GNYC11P21005 -> Requested name does not exist
SITES.CHASE.COM -> Requested name does not exist
LIVE.REZYNC.COM -> Requested name does not exist
RF15.CHASE.COM -> Requested name does not exist
ONLINE.ADP.COM -> Requested name does not exist
Z.MOATADS.COM -> Requested name does not exist
DISQUSADS.COM -> Requested name does not exist
RTB.GUMGUM.COM -> Requested name does not exist
PIPPIO.COM -> Requested name does not exist
X.BIDSWITCH.NET -> Requested name does not exist
B.ADMEDIA.COM -> Requested name does not exist
JS.STRIPE.COM -> Requested name does not exist
EC.WALKME.COM -> Requested name does not exist
IESS.HGS-BS.COM -> Requested name does not exist
J.MRPDATA.NET -> Requested name does not exist
15.TABOOLA.COM -> Requested name does not exist
MIDAS.CHASE.COM -> Requested name does not exist
WWW.HITC.COM -> Requested name does not exist
S0.2MDN.NET -> Requested name does not exist
SPRI17P10001 -> Requested name does not exist
PLAY.GOOGLE.COM -> Requested name does not exist
S8T.TEADS.TV -> Requested name does not exist
WWW.CHASE.COM -> Requested name does not exist
SPRI50B02006 -> 169.43.126.22
STUN.NAS.NET -> Requested name does not exist
WWW.VIZURY.COM -> Requested name does not exist
ESPN.COM -> Requested name does not exist
GMIL59B02001 -> Requested name does not exist
G.JWPSRV.COM -> Requested name does not exist
SCDN.CXENSE.COM -> Requested name does not exist
NT AUTHORITY -> Requested name does not exist
EB.WBMASON.COM -> Requested name does not exist
GMIL59P02001 -> Requested name does not exist
DE.TYNT.COM -> Requested name does not exist
CDN.WALKME.COM -> Requested name does not exist
PX.MOATADS.COM -> Requested name does not exist
ADS.YAHOO.COM -> Requested name does not exist
STUN.VEOH.COM -> Requested name does not exist
WWW.SEC.GOV -> Requested name does not exist
HBEVENTS.1RX.IO -> Requested name does not exist
A-NJ.1RX.IO -> Requested name does not exist
R.3GL.NET -> Requested name does not exist
WWW.DIANOMI.COM -> Requested name does not exist
STUN.VOXOX.COM -> Requested name does not exist
BIDDER.RTK.IO -> Requested name does not exist
L.SHARETHIS.COM -> Requested name does not exist
S.NTV.IO -> Requested name does not exist
T.SHARETHIS.COM -> Requested name does not exist
BAM.NR-DATA.NET -> Requested name does not exist
STUN.JUMBLO.COM -> Requested name does not exist
UM2.EQADS.COM -> Requested name does not exist
CK.CONNATIX.COM -> Requested name does not exist
WWW.CNN.COM -> Requested name does not exist
WWW2.BING.COM -> Requested name does not exist
RTB.NUI.MEDIA -> Requested name does not exist
GEO2.ADOBE.COM -> Requested name does not exist
NT SERVICE -> Requested name does not exist
WWW.JETBLUE.COM -> Requested name does not exist
WWW.PAYPAL.COM -> Requested name does not exist
STUN.2TALK.COM -> Requested name does not exist
OUT.REDDIT.COM -> Requested name does not exist
M.STRIPE.COM -> Requested name does not exist
CONNEXITY.NET -> Requested name does not exist
STUN.WWDL.NET -> Requested name does not exist
CDN.W55C.NET -> Requested name does not exist
THOR.RTK.IO -> Requested name does not exist
1898.DEMDEX.NET -> Requested name does not exist
RTR.INNOVID.COM -> Requested name does not exist
SPNQ15P01001 -> Requested name does not exist
CDN.UNID.GO.COM -> Requested name does not exist
PSA.CARAMBO.LA -> Requested name does not exist
UNID.GO.COM -> Requested name does not exist
T.PUBMATIC.COM -> Requested name does not exist
WWW.MSN.COM -> Requested name does not exist
WWW.AMAZON.COM -> Requested name does not exist
IMG.3LIFT.COM -> Requested name does not exist
ESPN.GO.COM -> Requested name does not exist
WWW.NYTIMES.COM -> Requested name does not exist
PAY.GOOGLE.COM -> Requested name does not exist
W.USABILLA.COM -> Requested name does not exist
WWW.TEST.COM -> Requested name does not exist
ROVER.EBAY.COM -> Requested name does not exist
NB.FIDELITY.COM -> Requested name does not exist
WWW.GSTATIC.COM -> Requested name does not exist
RS.GWALLET.COM -> Requested name does not exist
CDN8.VIZURY.COM -> Requested name does not exist
LOG.GO.COM -> Requested name does not exist
SNYC14P21003 -> Requested name does not exist
AURA.ALIGHT.COM -> Requested name does not exist
WWW.WSJ.COM -> Requested name does not exist
EU.DOCUSIGN.NET -> Requested name does not exist
PIPE.SKYPE.COM -> Requested name does not exist
U.OPENX.NET -> Requested name does not exist
A.TEADS.TV -> Requested name does not exist
AX.LEMNISK.CO -> Requested name does not exist
CAL.ESPN.COM -> Requested name does not exist
AD.TURN.COM -> Requested name does not exist
APP.HUBSPOT.COM -> Requested name does not exist
SNYC14P21001 -> Requested name does not exist
T.LKQD.NET -> Requested name does not exist
GPRI11P21001 -> 169.49.98.15
API.ALIGHT.COM -> Requested name does not exist
CP.HDFCBANK.COM -> Requested name does not exist
SNYC11P21003 -> 169.37.57.173
SPRI10P00054 -> 169.35.89.162
WWW.YELP.COM -> Requested name does not exist
SAML.ALIGHT.COM -> Requested name does not exist
VCDN.ADNXS.COM -> Requested name does not exist
GLON11P10043 -> Requested name does not exist
PIX.ADRTA.COM -> Requested name does not exist
CWS.CONVIVA.COM -> Requested name does not exist
A.ESPNCDN.COM -> Requested name does not exist
GNYC11P21003 -> Requested name does not exist
SYNC.RTK.IO -> Requested name does not exist
OTF.MSN.COM -> Requested name does not exist
ADS.ADAP.TV -> Requested name does not exist
SECURE.FLYR.IO -> Requested name does not exist
WWW.EENADU.NET -> Requested name does not exist
AEXP.DEMDEX.NET -> Requested name does not exist
VMG.HOST -> Requested name does not exist
BEA4.CNN.COM -> Requested name does not exist
TAG-NJ.1RX.IO -> Requested name does not exist
CDN.REVJET.COM -> Requested name does not exist
ONETAG-SYS.COM -> Requested name does not exist
WWW.WCPSS.NET -> Requested name does not exist
SAM.MSN.COM -> Requested name does not exist
PX.OWNERIQ.NET -> Requested name does not exist
DSP.V.FWMRM.NET -> Requested name does not exist
XTR.CARAMBO.LA -> Requested name does not exist
WWW.CDN-NET.COM -> Requested name does not exist
WWW.TAMGRT.COM -> Requested name does not exist
S.ADZMATH.COM -> Requested name does not exist
1179.XG4KEN.COM -> Requested name does not exist
CARS.USNEWS.COM -> Requested name does not exist
EU.HIPEROS.COM -> Requested name does not exist
MCPM.MARKIT.COM -> Requested name does not exist
ATT.INQ.COM -> Requested name does not exist
USV03754259 -> 169.49.6.226
WWW.MARVAL.COM -> Requested name does not exist
I.YTIMG.COM -> Requested name does not exist
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}