re = /(?:field|\G(?!\A))\[(\w+)\]/m
str = 'field[somevalue][anothervalue][other][some]...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end