const regex = /(?<![\.\*\d])(?:(?P<a>2(?:5[0-5]|[0-4]\d)|1\d{2})|(?:0)?(?P<a>[1-9]\d)|(?:00)?(?P<a>\d)|(?P<a>\*))\.(?:(?P<b>2(?:5[0-5]|[0-4]\d)|1\d{2})|(?:0)?(?P<b>[1-9]\d)|(?:00)?(?P<b>\d)|(?P<b>\*))\.(?:(?P<c>2(?:5[0-5]|[0-4]\d)|1\d{2})|(?:0)?(?P<c>[1-9]\d)|(?:00)?(?P<c>\d)|(?P<c>\*))\.(?:(?P<d>2(?:5[0-5]|[0-4]\d)|1\d{2})|(?:0)?(?P<d>[1-9]\d)|(?:00)?(?P<d>\d)|(?P<d>\*))(?![\.\*\d])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\.\\*\\d])(?:(?P<a>2(?:5[0-5]|[0-4]\\d)|1\\d{2})|(?:0)?(?P<a>[1-9]\\d)|(?:00)?(?P<a>\\d)|(?P<a>\\*))\\.(?:(?P<b>2(?:5[0-5]|[0-4]\\d)|1\\d{2})|(?:0)?(?P<b>[1-9]\\d)|(?:00)?(?P<b>\\d)|(?P<b>\\*))\\.(?:(?P<c>2(?:5[0-5]|[0-4]\\d)|1\\d{2})|(?:0)?(?P<c>[1-9]\\d)|(?:00)?(?P<c>\\d)|(?P<c>\\*))\\.(?:(?P<d>2(?:5[0-5]|[0-4]\\d)|1\\d{2})|(?:0)?(?P<d>[1-9]\\d)|(?:00)?(?P<d>\\d)|(?P<d>\\*))(?![\\.\\*\\d])', 'g')
const str = `*127.0.0.1 -> 127.0.0.1
192.168.0.1. -> 192.168.0.1
255.255.255.256 -> 255.255.255.255
192.168.**.* -> 192.168.*.*
255..1.15 -> 255.0.1.15
192.168.001.002 = 192.168.1.2
008.008.004.004 = 8.8.4.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}