#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\.]*\.[^_]+\.[^_]+$"
Local $sString = "this_is.ok.com" & @CRLF & _
"this_is.another_valid.domain.com" & @CRLF & _
"" & @CRLF & _
"this_one.is_not_ok.com" & @CRLF & _
"not_ok.com" & @CRLF & _
"also.not_ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")