package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-2][0-9]|3[0-1])\-(0[1-9]|1[0-2])\-\d{4}`)
var str = `31-12-1999
31-13-1999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}