import Foundation
let pattern = #"(const |)brand = await Faker\.\w+\((DefaultBrand)\).build\(\);((.|\n)+?)(?=defaultCmsSettingsFakeFactory)defaultCmsSettingsFakeFactory\(\)\.build(..)((.|\n)+?): (?=BrandSpecifics)(BrandSpecifics\.[\w_]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
beforeAll(async () => {
const brand = await Faker.makeCmsFactory(DefaultBrand).build();
TestBed.configureTestingModule({
imports: [ResponsibleGamingPageDepositLimitSubpageContainerTestingModule, ContainersInitialTestingModule],
providers: [
{ provide: Brand, useValue: brand },
{ provide: CMS_SETTINGS, useValue: defaultCmsSettingsFakeFactory().build() },
],
});
const cmsClientService = TestBed.inject(CmsClientService);
const cmsSlugger = TestBed.inject(CmsSluggerService);
const resultSlug = cmsSlugger.buildSlug({
brandSpecific: BrandSpecifics.BOO_CASINO,
metaContentType: MetaContentTypes.CONTENT_SECTION,
appContentType: 'brand',
property: '0',
instanceName: '0',
});
const result = await cmsClientService.getContent(resultSlug, LocaleNames.EN, false, 10);
const getContentBehavior = TestBed.inject(GetContentBehavior);
const config = (await getContentBehaviorConfigFakeFactory({ result, tags: {} })).build();
const actions = await getContentBehavior.run(config);
const store = TestBed.inject(Store);
actions.forEach((action) => store.dispatch(action));
await TestBed.compileComponents();
fixture = TestBed.createComponent(ResponsibleGamingPageDepositLimitSubpageContainer);
component = fixture.componentInstance;
fixture.detectChanges();
});
beforeAll(async () => {
const brand = await Faker.makeCmsFactory(DefaultBrand).build();
TestBed.configureTestingModule({
imports: [LoginDialogContainerTestingModule, ContainersInitialTestingModule],
providers: [
{ provide: Brand, useValue: brand },
{ provide: CMS_SETTINGS, useValue: defaultCmsSettingsFakeFactory().build() },
],
});
const cmsClientService = TestBed.inject(CmsClientService);
const cmsSlugger = TestBed.inject(CmsSluggerService);
const resultSlug = cmsSlugger.buildSlug({
brandSpecific: BrandSpecifics.BOO_CASINO,
metaContentType: MetaContentTypes.CONTENT_SECTION,
appContentType: 'brand',
property: '0',
instanceName: '0',
});
const result = await cmsClientService.getContent(resultSlug, LocaleNames.EN, false, 10);
const getContentBehavior = TestBed.inject(GetContentBehavior);
const config = (await getContentBehaviorConfigFakeFactory({ result, tags: {} })).build();
const actions = await getContentBehavior.run(config);
const store = TestBed.inject(Store);
actions.forEach((action) => store.dispatch(action));
await TestBed.compileComponents();
fixture = TestBed.createComponent(LoginDialogContainer);
component = fixture.componentInstance;
fixture.detectChanges();
});
beforeAll(async () => {
const brand = await Faker.makeCmsFactory(DefaultBrand).build();
TestBed.configureTestingModule({
imports: [NewVersionNoticeContainerTestingModule, ContentStoreTestingModule, ContainersInitialTestingModule],
providers: [
{ provide: Brand, useValue: brand },
{ provide: CMS_SETTINGS, useValue: defaultCmsSettingsFakeFactory().build() },
],
});
const cmsClientService = TestBed.inject(CmsClientService);
const cmsSlugger = TestBed.inject(CmsSluggerService);
const resultSlug = cmsSlugger.buildSlug({
brandSpecific: BrandSpecifics.BOO_CASINO,
metaContentType: MetaContentTypes.CONTENT_SECTION,
appContentType: 'brand',
property: '0',
instanceName: '0',
});
const result = await cmsClientService.getContent(resultSlug, LocaleNames.EN, false, 10);
const getContentBehavior = TestBed.inject(GetContentBehavior);
const config = (await getContentBehaviorConfigFakeFactory({ result, tags: {} })).build();
const actions = await getContentBehavior.run(config);
const store = TestBed.inject(Store);
actions.forEach((action) => store.dispatch(action));
await TestBed.compileComponents();
fixture = TestBed.createComponent(NewVersionNoticeContainer);
component = fixture.componentInstance;
fixture.detectChanges();
});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"const brandSpecific = $8;\n $1brand = await Faker.makeCmsFactory($2, brandSpecific).build();$3 defaultCmsSettingsFakeFactory().build({ brandSpecific })$4$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)