import Foundation
let pattern = #"^(?<User>[_a-z0-9-]+(\.[_a-z0-9-]+(?<GmailTag>\+[_a-z0-9-]+){1,1})*)@(?<Host>[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"kevimetal.matyrock+pruebasdecolegios@google.mail.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}