$re = '/(?!^\$0[1-9])(?=^(\$[0-9]+(\,[0-9]{3})*)+(\.[0-9]+)?$)^.{1,19}$|(?!^0[1-9])(?=^([0-9]+(\,[0-9]{3})*)+(\.[0-9]+)?$)^.{1,18}$/';
$str = '$1,122,222.222';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);