$re = '/((.*?)\.(.*))/m';
$str = 'South.6987556.Input.csv.cop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);