re = /(?:newProductsInfo: \[|\G(?!^)),?\K[^,\n]+(?>,\h+[^,\n]+)*/
str = 'newProductsInfo: [[$39 OFF] - Slytherin Snake Ear Cuffs - Low in Stock,FREE Mystery Box (Previously $30),The Jewelry Club: Exclusive VIP,[Exclusive Offer] / Discounted Mystery Box]
newProductsInfo: [[1] - $2 dollars,[2] New Product,[3] Hello,[4]Same, [5]Value]
newProductsInfo: [[1] - $2 dollars,[4]Same, [5]Value],[2] New Product,[3] Hello,[4]Same, [5]Value]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end