using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9])\.(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9])\.(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9])\.(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9]))\b";
string input = @"This REGULAR EXPRESSION is just for searching for dotted decimal IPv4 Adresses.
Unlike a shorter one, this one is made for seeing the numbers in seperate Mach-groups-thingy.
I also included some unit tests.. But i think they are not needed.
Below are some tests:
Valid:
0.0.0.0
1.2.3.4
127.0.0.1
8.8.4.4
8.8.8.8
255.255.255.255
249.0.0.1
0.1.255.254
98.139.180.149
69.89.31.226
Invalid:
999.999.999
290.250.2.6
256.259.20.255
Texts:
Google DNS Server IP is 8.8.8.8. As a alternative you can use 8.8.4.4.
The IP 127.0.0.1 (also known as localhost) is a 'loopback' IP-Adress, pointing to your computer.
Example pinging:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.
C:\Users\Example>ping google.com
Pinging google.com [212.6.83.44] with 32 bytes of data:
Reply from 212.6.83.44: bytes=32 time=42ms TTL=59
Reply from 212.6.83.44: bytes=32 time=55ms TTL=59
Reply from 212.6.83.44: bytes=32 time=35ms TTL=59
Reply from 212.6.83.44: bytes=32 time=27ms TTL=59
Ping statistics for 212.6.83.44:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 27ms, Maximum = 55ms, Average = 39ms
C:\Users\Example>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}