const regex = /^(\d{4})-(\d+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4})-(\\d+)$', '')
const str = `2015-023`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}