$re = '/(?<header_all>
(?<header_content>.+)
[ \t]*
\n
(?<!\\\\)
(?<header_type>[\=|\-]+)
[ \t]*
\n+
)/mx';
$str = 'Header
======
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);