re = /[:;?!](?![^><]*>)/m
str = 'out : < in : ! in ; ?! > : out : < ? in : in : > ! : out : '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end