re = /[^n]y|[^a]ny|a(?!ny)|an(?!y)|[^a]n(?=y)|n(?!y)|[^any\d]/m
str = 'I successfully mande a regex to include it is any 0-9 but don\'t know the way to exclude. any zny znk anz ny any n a n y
y ny ay zy any
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end