#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/[^,:]*\.\w+"
Local $sString = "In file included from /some/directoy/3.33A.37.2/something else/dogs.txt," & @CRLF & _
" from /some/directoy/something else/dogs.txt," & @CRLF & _
" from /some/directoyr/3.33A.37.2/something else/dogs.txt," & @CRLF & _
" from /var/log/xyz/10032008.log," & @CRLF & _
" from /var/log/xyz/test.c:29:" & @CRLF & _
"Solution:" & @CRLF & _
"please the file something.h has to be alone without others include, it has to be present in release letter, " & @CRLF & _
"in order to be included in /var/log/xyz/test.c automatically" & @CRLF & _
"Other Note: " & @CRLF & _
"The file something.c must contain the somethinge.h and not the ecpfmbsd.h because it doesn't contain C operative code.. everything good.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")