$re = '/(\d+).*?(\d+)/';
$str = '15 packs of 5
1 pack of 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);