use strict;
my $str = '{% if something %}
----------------
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
---- endif ----
{% endif %}
kjafgnkajngkjalkjg
{% if something %}
++++++++++++++++
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
++++ endif ++++
{% endif %}
';
my $regex = qr/ (?=
({%.if
(?:
(?>
(?:
(?! {%.if | endif.%}) .
)+
)*
| (?1)
)*
endif.%})
)
(?1)/xsmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}