// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([0-9]+\s?)+)\$").unwrap();
let string = "player number 8 have a nice day. the price is 1 000 $ or you have to pay 2000$.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}