$re = '/([()])*[0-9]/';
$str = '()3
)9
(2
)))3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);