$re = '/^(\d{0,5})(\.)?(\d{0,1})?$/m';
$str = '123.2
12345.2
1.2
12345
12345.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);