$re = '/^(?!.*aaa).*a{1,2}.*$/m';
$str = 'abaa
baab
baaab
aaab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);