$re = '/(?:^|(?<=\s))[A-Za-z0-9_\'\-]+(?=\s|$)/m';
$str = 'I don\'t know Sally\'s \'special\' friend';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);