$re = '/^[A-Za-z0-9,]+([\s-\s].+)$/';
$str = '0D - obvious deed
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);