package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(d)(?:ays?)?|(w)(?:eeks?)?`)
var str = `days
day
d
w
weeks
week
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}