$re = '/^\/[0-9]+$/m';
$str = '/123
/asd213
/1
123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);