use strict;
my $str = 'erewr-werwewerew-werwer';
my $regex = qr/(['^$.|?*+()\\])/p;
my $subst = '\\\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";