$re = '/([0-9]*)\.([0-9]*)N,( *)([0-9]*)\.([0-9]*)E/u';
$str = '50.4740817N, 14.5416525E';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);