#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\([\w:;'\"‘’\- /!]+\)"
Local $sString = "grek. afs." & @CRLF & _
"" & @CRLF & _
"mat. to‘r shaklidagi (to'rsimon) nomogramma; nomogramma (turli kattaliklar o ‘r- tasidagi o ‘zaro bog ‘lanishni ko ‘rsatadigan va ular- ni topishni osonlashtiradigan grafik chizma). mat. to‘r shaklidagi (to'rsimon) nomogramma; nomogramma (turli kattaliklar o ‘r- tasidagi o ‘zaro bog ‘lanishni ko ‘rsatadigan va ular- ni topishni osonlashtiradigan grafik chizma)." & @CRLF & _
"" & @CRLF & _
"1) bot. abaka daraxli yoki shu daraxtdan qilingan ip; 2) kanoptola; 3) me'mor. boshtirgak. 1) bot. abaka daraxli yoki shu daraxtdan qilingan ip; 2) kanoptola; 3) me'mor. boshtirgak." & @CRLF & _
"" & @CRLF & _
"I) orqaga; 2) orqasidan; 3) or- qasi bilan; to hold oneself - from......dan o‘zini uzoqda olib yurmoq; to stand ~ from dan o'zini olib qochmoq. I) orqaga; 2) orqasidan; 3) or- qasi bilan; to hold oneself - from......dan o‘zini uzoqda olib yurmoq; to stand ~ from dan o'zini olib qochmoq." & @CRLF & _
"" & @CRLF & _
"yitr. katta o‘g‘irlik yoki molni o‘g‘irlash. yitr. katta o‘g‘irlik yoki molni o‘g‘irlash." & @CRLF & _
"" & @CRLF & _
"marmar plita. marmar plita." & @CRLF & _
"" & @CRLF & _
"deng. qayiqning orqasidan, qayiqning izidan; 2.prep, orqasida(n), ketida(n); keyin; ~ the beam traverz orqasidan (traverz- kemaning yo'nalishiga perpendikular bo'lgan yon I onion). deng. qayiqning orqasidan, qayiqning izidan; 2.prep, orqasida(n), ketida(n); keyin; ~ the beam traverz orqasidan (traverz- kemaning yo'nalishiga perpendikular bo'lgan yon I onion)." & @CRLF & _
"" & @CRLF & _
"1) bosh tortmoq; bekor qilmoq; to ~ a right huquqni bekor qilmoq; 2) tashlab ketmoq; 3) adashtirmoq; 4) qoldir- moq; 2. n odobsizlik; o'zini tuta olmaslik. 1) bosh tortmoq; bekor qilmoq; to ~ a right huquqni bekor qilmoq; 2) tashlab ketmoq; 3) adashtirmoq; 4) qoldir- moq; 2. n odobsizlik; o'zini tuta olmaslik." & @CRLF & _
"" & @CRLF & _
"bosh tortgan, bahridan o'tgan, voz kechgan; tashlab ketilgan, qoldi- rilgan; tashlandiq, tashlandi; an ~ child tashlab ketilgan bola. bosh tortgan, bahridan o'tgan, voz kechgan; tashlab ketilgan, qoldi- rilgan; tashlandiq, tashlandi; an ~ child tashlab ketilgan bola." & @CRLF & _
"" & @CRLF & _
"kemani falokatdan sug'urta qilish. kemani falokatdan sug'urta qilish." & @CRLF & _
"" & @CRLF & _
"1) qarovsiz qoldirib ketish; 2) yur. bolasini yoki xotinini tashlab ketish. 1) qarovsiz qoldirib ketish; 2) yur. bolasini yoki xotinini tashlab ketish." & @CRLF & _
"" & @CRLF & _
"1) kamsitish; 2) tu- shirish (mansabdan). 1) kamsitish; 2) tu- shirish (mansabdan)." & @CRLF & _
"" & @CRLF & _
"uyaltirmoq, uyallirib qo'ymoq, uyatga qoldirmoq, xijolat qilmoq, xijolatga solmoq. uyaltirmoq, uyallirib qo'ymoq, uyatga qoldirmoq, xijolat qilmoq, xijolatga solmoq." & @CRLF & _
"" & @CRLF & _
"uyalib qolish, xijolat bo'lish, xijolat tortish. uyalib qolish, xijolat bo'lish, xijolat tortish." & @CRLF & _
"" & @CRLF & _
"I) kuch-quvvatdan qolish, zaiflashish; ~ of noise a) shovqin bilan kurashish; b) shovqinning pasayishi; 2) tushirish (narxni, soliqni); to make - narxni tushirmoq; 3) yur. bekor qilish; - of action sud ishini to‘x- tatmoq. I) kuch-quvvatdan qolish, zaiflashish; ~ of noise a) shovqin bilan kurashish; b) shovqinning pasayishi; 2) tushirish (narxni, soliqni); to make - narxni tushirmoq; 3) yur. bekor qilish; - of action sud ishini to‘x- tatmoq." & @CRLF & _
"" & @CRLF & _
"to'qim. arqoq. to'qim. arqoq." & @CRLF & _
"" & @CRLF & _
"abbat unvoni, abbatlik. abbat unvoni, abbatlik." & @CRLF & _
"" & @CRLF & _
"abbatlik (katoliklar monastiri va unga qarashli yer-mulk), monastir; the Abbey Vestminstr abbatligi. abbatlik (katoliklar monastiri va unga qarashli yer-mulk), monastir; the Abbey Vestminstr abbatligi." & @CRLF & _
"" & @CRLF & _
"abbat (1. katolik erkaklar mo- nastirining boshlig'i; 2. Fransiyada: katoliklar ruhoniysi). abbat (1. katolik erkaklar mo- nastirining boshlig'i; 2. Fransiyada: katoliklar ruhoniysi)." & @CRLF & _
"" & @CRLF & _
"qisqartirmoq; ~d qisqartirilgan. qisqartirmoq; ~d qisqartirilgan." & @CRLF & _
"" & @CRLF & _
"qisqartirish; qis- qartma. qisqartirish; qis- qartma." & @CRLF & _
"" & @CRLF & _
"1) alifbo; ~ book alifbo kitobi; 2) asos, negiz. 1) alifbo; ~ book alifbo kitobi; 2) asos, negiz." & @CRLF & _
"" & @CRLF & _
"kechmoq, voz kechmoq, yuz o'girmoq, bahridan o'tmoq, o'zini mahrum qilmoq (taxtdan, hokimiyatdan, o'zhuquqidan). kechmoq, voz kechmoq, yuz o'girmoq, bahridan o'tmoq, o'zini mahrum qilmoq (taxtdan, hokimiyatdan, o'zhuquqidan)." & @CRLF & _
"" & @CRLF & _
"kechish, voz kechish, yuz o'girish, bahridan o'tish, o'zini mahrum qilish (nimadandir). kechish, voz kechish, yuz o'girish, bahridan o'tish, o'zini mahrum qilish (nimadandir)." & @CRLF & _
"" & @CRLF & _
"1) anat. qorin, qorin bo'shlig'i; retracted - ichiga kirgan qorin; 2) zool. qorin (qushlarda). 1) anat. qorin, qorin bo'shlig'i; retracted - ichiga kirgan qorin; 2) zool. qorin (qushlarda)." & @CRLF & _
"" & @CRLF & _
"anat. qoringa oid, qorin. anat. qoringa oid, qorin." & @CRLF & _
"" & @CRLF & _
"semiz, yo'g'on, qor- ni katta. semiz, yo'g'on, qor- ni katta." & @CRLF & _
"" & @CRLF & _
"anat. ajratadigan (mus- kullar to'g'risida), mushaklarning tortilishi. " & @CRLF & _
"anat. ajratadigan (mus- kullar to'g'risida), mushaklarning tortilishi." & @CRLF & _
"" & @CRLF & _
"o‘g‘ri, o‘g‘irlovchi; olib- qochar (asosan, bolalar va ayollami). o‘g‘ri, o‘g‘irlovchi; olib- qochar (asosan, bolalar va ayollami)." & @CRLF & _
"" & @CRLF & _
"deng. kemaning izidan, orqa- sidan. deng. kemaning izidan, orqa- sidan." & @CRLF & _
"" & @CRLF & _
"toqat qilmoq, chidamoq. toqat qilmoq, chidamoq." & @CRLF & _
"" & @CRLF & _
"1) alifbo tartibida joylashtirilgan; 2) oddiy, sodda; 2. n savod o'rgatadigan, o'qituvchi. 1) alifbo tartibida joylashtirilgan; 2) oddiy, sodda; 2. n savod o'rgatadigan, o'qituvchi." & @CRLF & _
"" & @CRLF & _
"1) ko'rpa-to'shakda; karavotda; 2) ko'rpa-to'shakka, karavotga. 1) ko'rpa-to'shakda; karavotda; 2) ko'rpa-to'shakka, karavotga." & @CRLF & _
"" & @CRLF & _
"bat. oq terak. bat. oq terak." & @CRLF & _
"" & @CRLF & _
"log'chumchuq (modasi). log'chumchuq (modasi)." & @CRLF & _
"" & @CRLF & _
"1) to'g'ri yo'ldan chiqish; 2) biol. normal turdan chetga chiqish. 1) to'g'ri yo'ldan chiqish; 2) biol. normal turdan chetga chiqish." & @CRLF & _
"" & @CRLF & _
"1) adashgan, adashib qolgan, yo'lini yo'qotib qo'ygan; 2) og‘gan, chetga chiqqan, burilib ketgan; a plane on an - course belgilangan yo'ldan chetga chiqib ketgan samolyot. 1) adashgan, adashib qolgan, yo'lini yo'qotib qo'ygan; 2) og‘gan, chetga chiqqan, burilib ketgan; a plane on an - course belgilangan yo'ldan chetga chiqib ketgan samolyot." & @CRLF & _
"" & @CRLF & _
"adashish, adashib qolish, yoMini yo'qotish. adashish, adashib qolish, yoMini yo'qotish." & @CRLF & _
"" & @CRLF & _
"yomon ishga undamoq (in): to - smb. in a crime yur. kimnidir jinoyat sodir etish- ga undamoq. yomon ishga undamoq (in): to - smb. in a crime yur. kimnidir jinoyat sodir etish- ga undamoq." & @CRLF & _
"" & @CRLF & _
"ig‘vo, fitna. ig‘vo, fitna." & @CRLF & _
"" & @CRLF & _
"1) sherik; 2) g'iybatchi, g'ala- mis, fitnachi. 1) sherik; 2) g'iybatchi, g'ala- mis, fitnachi." & @CRLF & _
"" & @CRLF & _
"1) noma’lum, mavhum holat; 2) yur. vaqtincha amalda bo'lmaslik, vaqtincha bekor qilinish (qonun, huquq): the question is in- bu masalani ko'rib chiqish to'xtatildi; this rule has fallen into - bu qonun eskirgan (boshqa amal qilmaydi); in - a) mavhum, kutish holatida: b) egasiz (meros to'g'- risida); d) vaqtincha bekor qilingan (qonun to ‘g 'risida). 1) noma’lum, mavhum holat; 2) yur. vaqtincha amalda bo'lmaslik, vaqtincha bekor qilinish (qonun, huquq): the question is in- bu masalani ko'rib chiqish to'xtatildi; this rule has fallen into - bu qonun eskirgan (boshqa amal qilmaydi); in - a) mavhum, kutish holatida: b) egasiz (meros to'g'- risida); d) vaqtincha bekor qilingan (qonun to ‘g 'risida)." & @CRLF & _
"" & @CRLF & _
"1) juda yomon ko'rmoq; nafrat bilan qaramoq; 2) so'zl. toqat qila olmaslik; yoqtirmaslik; my son ~s being idle o'g'lim bekor yurishni yoqlirmaydi. 1) juda yomon ko'rmoq; nafrat bilan qaramoq; 2) so'zl. toqat qila olmaslik; yoqtirmaslik; my son ~s being idle o'g'lim bekor yurishni yoqlirmaydi." & @CRLF & _
"" & @CRLF & _
"jirkanish, nafratlanish, yomon ko'rish: to hold in - nafratlanmoq, jir- kanmoq. jirkanish, nafratlanish, yomon ko'rish: to hold in - nafratlanmoq, jir- kanmoq." & @CRLF & _
"" & @CRLF & _
"1) nafrat uyg'otadigan: 2) birga yashay olmaydigan, birga bo'lolmay- digan (to - bilan). 1) nafrat uyg'otadigan: 2) birga yashay olmaydigan, birga bo'lolmay- digan (to - bilan)." & @CRLF & _
"" & @CRLF & _
"rioya qilish ( nimagadir)-, ~ by rules qoidaga rioya qilmoq. rioya qilish ( nimagadir)-, ~ by rules qoidaga rioya qilmoq." & @CRLF & _
"" & @CRLF & _
"(abode, abided, abidden) 1) chidamli (pishiq) bo'lmoq; buzilmas bo'lib qolmoq: 2) ya.shamoq: umr ko'rmoq, istiqomat qilmoq; ~ at biror joyda (istiqomat qilmoq) yashamoq; - by sodiq bo'lib qolmoq: rioya qilmoq: amal qilmoq; to - by one’s promises so'zining (va’dasining) ustidan chiqmoq: my father ~s by what he said mening otam doimo aytganini qiladi; - in biror joyda (istiqomat qilmoq) yashamoq; - with kirn bilandirqolmoq. (abode, abided, abidden) 1) chidamli (pishiq) bo'lmoq; buzilmas bo'lib qolmoq: 2) ya.shamoq: umr ko'rmoq, istiqomat qilmoq; ~ at biror joyda (istiqomat qilmoq) yashamoq; - by sodiq bo'lib qolmoq: rioya qilmoq: amal qilmoq; to - by one’s promises so'zining (va’dasining) ustidan chiqmoq: my father ~s by what he said mening otam doimo aytganini qiladi; - in biror joyda (istiqomat qilmoq) yashamoq; - with kirn bilandirqolmoq." & @CRLF & _
"" & @CRLF & _
"rib. asabiylashni pasay- tirmoq. rib. asabiylashni pasay- tirmoq." & @CRLF & _
"" & @CRLF & _
"1) past, xarob, g'arib: 2) kamsitish, pastga urish. 1) past, xarob, g'arib: 2) kamsitish, pastga urish." & @CRLF & _
"" & @CRLF & _
"voz kechish, yuz o'girish. voz kechish, yuz o'girish." & @CRLF & _
"" & @CRLF & _
"yuz o'girmoq, voz kechmoq: to - one’s religion o‘z dinidan yuz o'girmoq. yuz o'girmoq, voz kechmoq: to - one’s religion o‘z dinidan yuz o'girmoq." & @CRLF & _
"" & @CRLF & _
"ko'kragidan (bag'ridan) tortib olish (bolani). ko'kragidan (bag'ridan) tortib olish (bolani)." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")