re = /^[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9](?:\.[a-zA-Z]{2,})+$/m
str = 'xy.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end