$re = '/^/';
$str = '<?php
namespace App\\Jobs\\Library\\Domain;
use Illuminate\\Bus\\Queueable;
use App\\Services\\YorLinkService;
use Illuminate\\Queue\\SerializesModels;
use Illuminate\\Queue\\InteractsWithQueue;
use Illuminate\\Contracts\\Queue\\ShouldQueue;
use Illuminate\\Foundation\\Bus\\Dispatchable;
class AddDomainLink implements ShouldQueue
{
use Dispatchable, InteractsWithQueue, Queueable, SerializesModels;
protected string $link_id;
protected string $domain_id;
protected string $path;
protected YorLinkService $yorLinkService;
/**
* Create a new job instance.
*
* @param $link_id
* @param $domain_id
* @param $path
*/
public function __construct(string $link_id, string $domain_id, string $path)
{
$this->yorLinkService = new YorLinkService;
$this->link_id = $link_id;
$this->domain_id = $domain_id;
$this->path = $path;
}
/**
* @param $yorLinkService
*/
public function setYorLinkServiceMock($yorLinkService)
{
$this->yorLinkService = $yorLinkService;
}
/**
* Execute the job.
*
* @return void
*/
public function handle()
{
$this->yorLinkService->createLink([
\'link_id\' => $this->link_id,
\'domain_id\' => $this->domain_id,
\'path\' => $this->path
]);
}
}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);