$re = '/^ *\d{1,3}(?:\.\d{3})*(?:,\d{1,2})?$/m';
$str = ' 9,99
99,99
999,99
9.999,99
99.999,99
999.999,99
9.999.999,99
99.999.999,99
999.999.999,99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);