# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"variants\[([0-9]{6})\]\[1\]\[([0-9]{1,6})\] \= 237228\;"
test_str = ("var variants = [];\n"
"variants[208091] = [[80.00, 958, new Image(), '8.00', 80.00, \"LUG-CENTRIC-SPACERS\"],{},{},[]];\n"
"variants[208091][1][36366] = 237228;\n"
"variants[208092] = [[80.00, 941, new Image(), '8.00', 80.00, \"4112-5-55-L\"],{},{},[]];\n"
"variants[208092][1][36366] = 237229;\n"
"variants[208093] = [[80.00, 957, new Image(), '8.00', 80.00, \"4112-5-55-LM\"],{},{},[]];\n"
"variants[208093][1][36366] = 237230;\n"
"variants[208094] = [[80.00, 954, new Image(/r), '8.00', 80.00, \"4112-6-55-L\"],{},{},[]];\n"
"variants[208094][1][36366] = 237231;\n"
"variants[208095] = [[115.00, 948, new Image(1), '8.00', 115.00, \"4112-8-65-L\"],{},{},[]];\n"
"variants[208095][1][36366] = 237232;\n"
"variants[208096] = [[115.00, 958, new Image(69), '8.00', 115.00, \"4112-8-65-LM\"],{},{},[]];\n"
"variants[208096][1][36366] = 237233;\n"
"variants[216938] = [[80.00, 998, new Image(), '8.00', 80.00, \"4112-6-55-14-L\"],{},{},[]];\n"
"variants[216938][1][36366] = 244691;\n"
"variants[216939] = [[115.00, 1000, new Image(), '8.00', 115.00, \"4112-8-170-L\"],{},{},[]];\n"
"variants[216939][1][36366] = 244692;\n"
"variants[218025] = [[80.00, 998, new Image(), '8.00', 80.00, \"4112-5-45-L\"],{},{},[]];\n"
"variants[218025][1][36366] = 245809;\n"
"variants[228776] = [[115.00, 1000, new Image(), '8.00', 115.00, \"4112-8-180-L\"],{},{},[]];\n"
"variants[228776][1][36366] = 254512;\n"
"variants[228819] = [[80.00, 1000, new Image(), '8.00', 80.00, \"4112-5-150-L\"],{},{},[]];\n"
"variants[228819][1][36366] = 254558;\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.