#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<palavrasIgnoradas>(?<!p)um|uma|e|o|são|é|como|de|em|as|os|a|se|ao|na|por|sem|tem|além|essa|""|ser|mas|também|para|no|eles|:|isso|ele|ela|elas|do|pela|pelo|nas|nos|dessa|desse|que|quais|da|ou|dar|aquela|aquele|isto|já|Nós|[0-9]|nesta|neste|É|esse|nestas|nestes|com|este|estes) |(?<palavrasAceitas>[a-záéóíàãêõçúâÇ&ôA-ZÃÂÈÀÁÉÊÓÒÊÍÌÓÒÔÕÚÙ]+)"
Local $sString = "O que vai afetar na vida das pessoas comuns a retirada do selo de bom pagador do Brasil pela Standard & Poor's? O que significa essa perda do grau de investimento?" & @CRLF & _
"" & @CRLF & _
"Se fosse uma pessoa, é como se o Brasil fosse considerado agora um cliente com um risco maior de dar calote. A consequência: terá que pagar uma taxa de juros maior para os credores se quiser continuar pegando dinheiro emprestado." & @CRLF & _
"" & @CRLF & _
"Como reflexo, as empresas brasileiras também devem sofrer mais para captar dinheiro." & @CRLF & _
"" & @CRLF & _
"Possíveis efeitos nos preços, no crédito e nos empregos" & @CRLF & _
"Essa conta mais alta das empresas deve ser repassada para o consumidor, que irá pagar mais pelos produtos ou por empréstimos, segundo o professor de Finanças Alexandre Cabral. Mas há luz no fim do tunel. "Mas o Brasil não acabou, há oportunidades de ganho para quem investir na aplicação certa."" & @CRLF & _
"" & @CRLF & _
"Mauro Calil, especialista em investimentos do banco Ourinvest, concorda que não é uma "catástrofe", mas diz que as pessoas podem sentir uma piora na restrição ao crédito, aumento da inflação e, possivelmente, alta do desemprego." & @CRLF & _
"" & @CRLF & _
""Será como uma dor de dente que não passa tão fácil e ainda tende a aumentar", diz." & @CRLF & _
"" & @CRLF & _
"Na opinião de Fabio Gallo, professor de Finanças da FGV-SP e PUC-SP, vai ficar mais difícil para a economia se recuperar, e isso terá reflexos no desemprego e na renda do trabalhador. "Não acabou o mundo, vivemos assim [sem grau de investimento] até 2008. Mas isso não quer dizer que não é ruim", diz." & @CRLF & _
"" & @CRLF & _
"Juros e dólar devem subir; prefira investimentos pós-fixados" & @CRLF & _
"Os especialistas acreditam que o efeito imediato do rebaixamento será uma alta das taxas de juros e também do dólar. Calil afirma que a moeda norte-americana pode atingir R$ 4,20." & @CRLF & _
"" & @CRLF & _
"O dólar alto deve puxar para cima a inflação, o que irá diminuir o poder de compra das pessoas." & @CRLF & _
"" & @CRLF & _
"Para quem tem dinheiro para investir, a melhor aplicação serão os investimentos pós-fixados (que acompanham uma determinada taxa, como a Selic ou o CDI)." & @CRLF & _
"" & @CRLF & _
"Todos os demais investimentos merecem cautela, tais como ações, títulos prefixados e dólar." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")