import re
regex = re.compile(r"^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Rough work iconoclasm but the only way to get the truth. Oliver Wendell Holmes\n"
"Rough work, iconoclasm, but the only way to get the truth. Oliver Wendell Holmes\n\n"
"Rule No. 1: Never lose money. Rule No. 2: Never forget rule No. 1. Warren Buffett\n"
"Rule No.1: Never lose money. Rule No.2: Never forget rule No.1. Warren Buffett\n\n"
"Self-esteem isn't everything, it's just that there's nothing without it. Gloria Steinem \n"
"Self-esteem isn't everything it's just that there's nothing without it. Gloria Steinem\n\n"
"You said she's a senior? Babe we're all crazy.\n"
"You said, she's a senior! Babe we're ALL crazy.\n"
"You said, she's a senior? Babe we're ALL crazy!\n\n"
"a\n"
"a a\n"
"a a a\n\n"
"a\n"
"a b\n"
"a b c\n"
"a b\n"
"a")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)