# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s1[A-Za-z]"
test_str = ("-ABC046Y 1SMITH/FREDMR \n"
".L/JCD5CQ \n"
".R/TKNE HK1 6002300348396/1-SMITH/FREDMR \n"
".R/SEAT HK1 9F \n"
".R/FQTV AB 60042576-1SMITH/FREDMR 1DOE/JANEMISS \n"
".L/JC93QW \n"
".R/TKNE HK1 6002300219029/2-1DOE/JANEEMISS \n"
".R/SEAT HK1 8A \n"
".R/CHKD HK1 011-1DOE/JANEMISS 1PRESLEY/ELVISMR-A2 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.