re = /(?<=\]).*?(?=\[)/m
str = 'abcabc]substrings[kkkkkkk]iwant[12345]tohave[!@#$%]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end