package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\u0000-\u007F]|\w)+`)
var str = `können`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}