re = /(?|(["'`])(Test)\1|\(((Test)\)))/m
str = '"Test"
\'Test\'
`Test`
(Test)
Test"
\'Test
Test`
(Test
"Test\'
\'Test"
`Test
Test)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end