re = /^[_A-Za-z0-9+-]+([.'’][_A-Za-z0-9-]+)*@[_A-Za-z0-9-]+(?:\.[_A-Za-z0-9-]+)*\.[A-Za-z]{2,}$/m
str = '**Valid emails**:
test@gmail.com
test\'s@gmail.com
t@gmail.com
**Invalid emails**:
\'test@gmail.com
test\'@gmail.com
\'test\'@gmail.com
test\'\'s@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end