package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)surveilr\[(?P<nature>[^]]*)\]`)
var str = `myfile.surveilr[json]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}