$re = '/[1-9]{1,2}[\/]+[1-9]{1,2}[\/]+[1-9]{2,4}/m';
$str = '12/8/1999
29/7/99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);