package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)a`)
var str = `A or a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}