#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<! [a-z]| [a-z]{2})\.(?! |\d|\.)"
Local $sString = "C.J. This is my example text. After this sentence there is no space after dot.What should? I want PHP to add whitespace in that case, but not after sentence where I already have white space or like now 3times dot...Another thing is that it can be written how great is to win 1.000.000 on lottery but I really don't want it to be 1. 000. 000 after edititng... Also C.J. must stay C.J. and not C. J.... wow that is hard :)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")