$re = '/^(.*?)carro/';
$str = 'o cara da pamonha bateu com o carro no carro de fulano';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);