const regex = /(?:^[a-z])(?:\w)*(?:[a-z0-9]$)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^[a-z])(?:\\w)*(?:[a-z0-9]$)', 'i')
const str = `Group4_5_2ekjgs_sdgflknds453`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}